Mi primer hackintosh

716avullliL._SL1000_

Acabo de montar mi primer hackintosh, no sin algún que otro dolor de cabeza.

Ya pondré la configuración utilizada pero el resumen es este:

Por unos 1300 € obtienes unos impresionantes resultados:

GeekBench3D            4185/16445
LuxMark 2297
BruceX 26 segundos

 

Y compara con el nuevo iMac con el mejor procesador i7@4Ghz y la mejor gráfica (R9 M295X):

LuxMark                                                            1656
BruceX 35 segundos

 

 

Midiendo el rendimiento en FCPX con BruceX

FCP-X-10.2

Una de las formas de medir el rendimiento de Final Cut Pro es con el test BruceX.

Es muy sencillo de realizar. Tenéis las instrucciones originales en inglés aquí.

1- Descargad el fichero XML con el proyecto aquí.

2- Abre QuickTime player and Final Cut Pro al mismo tiempo

3- En Final Cut Pro X, ir a Final Cut Pro->Preferences, y en la pestaña Playback aseguraos de tener a off el parámetro ‘Background Render’.

4- Importar el fichero XML descargado con File->Import:XML

5- Haz clic sobre el timeline ‘BruceX Test – 5K ‘

6- Exportar a  QuickTime Movie seleccionando File->Share->Master File.

7- Selecciona la pestaña Settings y en Video Codec selecciona ProRes422

8- En la sección Open With, elige QuickTime Player

9- Haz clic en Next y selecciona la carpeta donde queremos que se genere el render.

10- Prepara el cronómetro y activalo en el momento de hacer clic en Save. Páralo cuando veas que la peli se abre en QuickTime Player y para el cronómetro.

Estaría bien confeccionar una lista con vuestros resultados para ver qué GPUs van mejor para FCPX en nuestros MacPros. Si ponéis los resultados que os salen a vosotros en los comentarios iré actualizando esta lista.

No olvidéis poner las características de CPUs y GPUs que utilicéis.

 

Test BruceX

MBP (i7 2.7Ghz – GeForce GT 650M) 60 segundos
MacPro 2,1 (2x Xeon 3Ghz – MSI R9 280x Gaming) 95 segundos
MacPro 3,1 (14Gb RAM – GTX680) 103 segundos
MacPro 3,1 (14Gb RAM – GTX680 flasheada) 90 segundos
Hackintosh i7@4.3Ghz (16Gb RAM – MSI R9 280x) 26 segundos
MacPro 6 cores + 2x D500 + 16Gb 29 segundos

 

 

 

Instalación paso a paso de Yosemite en MacPro 1,1

apple_mac_pro

He creado este post para ir incorporando las dudas y problemas que tengan los lectores del blog, y que normalmente las expresan en los comentarios. De esta forma, espero que tengáis más a mano toda la información necesaria y todos los detalles para facilitar la instalación.

También pongo los aportes de lectores que aunque no son míos (y así lo indicaré) creo que pueden venirlo muy bien a otros.

Con estas instrucciones sacadas del hilo de MacRumors, nunca ha sido tan fácil la instalación de Yosemite en nuestros MacPro.

1- Te descargas la imagen del instalador de Yosemite ya modificado con el boot.efi de Piker-Alfa

2- Restaurar esa imagen en una unidad USB con Disk Utility. Instrucciones aquí.

3- Arrancas el MacPro desde la unidad USB.

4- Sigues las instrucciones del instalador.

Voila.

Preguntas

P: El problema parece estar en que no arranca desde el USB. Cuando suena el arranque pulso C y aparece antes de la manzanita una carpeta con un interrogante dentro. Supongo que esto se debe a que no esta bien el disco de arranque, pero he probado con dos pen drives distintos y sigue igual….

En este artículo de Apple se puede ver los pasos que se deben cumplir para poder arrancar desde el disco externo. ¿Has realizado la partición del disco externo en modo GUID Partition Table? NOTA: Este paso no es necesario, la imagen que pasamos a nuestro USB ya tiene toda la información necesaria para el arranque.

En System Preferences -> Startup Disk, seleccionamos el disco USB con la instalación de Yosemite.

 

Screen Shot 2015-04-24 at 9.02.48

Si en la pantalla anterior solo se ve el disco de arranque:

Screen Shot 2015-04-24 at 9.03.07

es que no hemos realizado bien el paso de copiar la imagen del instalador de Yosemite en el disco USB. De hecho esto es una prueba perfecta para ver si vamos a tener algún problema antes de arrancar.

También se puede seleccionar el disco de arranque al reiniciar el MacPro y dejar pulsada la tecla Option, pero es mejor el paso anterior para ir comprobando paso a paso si vamos realizando todos los pasos correctamente.

P: Sigo con problemas….. he bajado de nuevo la imagen dmg, la he restaurado en otro pendrive, he seleccionado reiniciar desde el Pendrive en Preferencia del Sistema/Disco de Arranque, y cuando intento bloquearlo para que no se hagan cambios me suelta un :”La herramienta bless no ha podido establecer el disco de arranque actual.”

Por supuesto no instala desde el USB

Lo primero es lo primero, ¿qué significa “intento bloquearlo para que no se hagan cambios”?

Por otro lado, si hacemos un man bless en el terminal o simplemente buscamos en google “OSX bless” nos dice que es una herramienta que modifica el sistema de ficheros para activar el flag boot. Es decir que lo hace “arrancable”.

bless is used to modify the volume bootability characteristics of
filesystems, as well as select the active boot volume. bless has 6 modes
of execution: Folder Mode, Mount Mode, Device Mode, NetBoot Mode, Info
Mode, and Unbless Mode.

Ahora ya puedo empezar a entender que “bloquear para que no haga cambios” puede significar que pones tu disco USB en modo lectura (me imagino que será una tarjeta de memoria o algo así). Si así fuera, efectivamente podríamos tener el error de este tipo al seleccionar esa unidad para que arranque.

No os lo pongáis difícil, seguid los pasos sin saltaros ninguno y por supuesto sin inventaros pasos adicionales.

Al final el problema era que se estaba utilizando un hub USB para conectar el disco con el instalador de Yosemite, en cuanto se conecto al frontal de la carcasa, OSX reconoció de inmediato el disco y nuestro lector pudo actualizar. Probablemente por un problema de exceso de consumo de los dispositivos conectados al hub.

Otro consejo aprendido, a la hora de instalar Yosemite desde USB, evitad problemas conectando directamente el disco USB con el instalador al MacPro.


P: He adquirido una GTX 660 para mi macpro 1.1 con ML, pero no arranca. Entiendo que hay que instalar antes Mavericks? O es que hago algo mal…

Instala primero Yosemite con la gráfica original.

Una vez instalado y comprobado que Yosemite funciona, podrás comprobar que el UI va extremadamente lento. La gráfica original apenas puede ni mover la ventana del Finder.

Haz un shutdown y desconecta la alimentación.

Cambia la gráfica y arranca de nuevo.

No tendrás pantalla de arranque, pero después de un rato verás que te OSX arranca perfectamente.

Más información en el post que publiqué con los detalles de la instalación.


P: He instalado Yosemite por que me pedia la nueva versión de Final Cut tenerlo. Pero esta versión que he descargado es la 10.10 y me pide la 10.10.2. Podría actualizarla sin mas?

Pues NO, como norma general, cada vez que hay una actualización se corre el riesgo de que Apple reemplace el fichero boot.efi de Piker-Alfa y nos deje nuestro MacPro sin arrancar.

Lo más fácil que podemos hacer viene explicado, donde sino, en la primera página del hilo de MacRumors.

Se trata del script PikeYoseFix que guarda una copia del boot.efi de Piker-Alfa y cada vez que se reiniciar la máquina lo sustituye por el que exista. Con este script instalado ya podemos estar tranquilos de actualizar nuestro OSX (todo lo tranquilo que se puede estar en este mundo, claro, recordad que ya nadie nos da soporte). Ojo, no hablo de actualizaciones mayores como el futuro 10.11. Cuando llegue ese momento, calmad los nervios y leed el blog.

Para instalar PikeYoseFix.

1- Descargarlo y ejecutarlo desde aqui

2- Reiniciar la máquina 2 veces.

3- Actualizar OSX

[Power users] Para más información leed sobre launchd, el cron de Unix de toda la vida supervitaminado. Desde terminal $man launchd

FYI: También comentarte un par de cosas. Compre un bluetooth externo y me empezaba a dar problemas con Mavericks. Me han regalado el ratón sin cable de apple y no me lo reconocía. Al instalar Yosemite, a la primera me ha enganchado.
Tambien al arrancar el ordenador, no me reconocia la salida de audio de los altavoces. Solo el interno. Ha sido reiniciar el ordenador y renocerlos.

Gracias Axier, parece que Yosemite es viagra para el abuelo.

 

OVERVIEW by Planetary Collective


via IFTTT